History always repeats itself and sometimes that's good. Here's a second chance to be part of it: tmdtc.com

Saturday, 12 July 2008

Updating rubygems on debian

Note to myself:

if you want to update the rubygems package installed by Debian, edit /usr/bin/gem and add those two lines after "require 'rubygems'":

require 'rubygems/gem_runner'
require 'rubygems/open-uri'

then you can update ruby gems with

gem update --system

1 comment:

James Vautin said...

this hack doesn't work on etch with rubygems from backports. :\

in fact, gem_runner is already in there.